Giriş Yap / Kayıt Ol
ersin

WM Aracı'na üyelikler tekrar açıldı! Kayıt olmak için TIKLAYIN!

2Beğeni
  • 1 Yazan ruzgarhost
  • 1 Yazan aydmem

Cevap Yaz Favorilerime Ekle
Seçenekler Stil
Geri Git   Forum > > HTML - CSS - XML

Temadaki İkonlar Görünmüyor

  #1  
Okunmamış 14 Ocak 2020, 15:43
Avatar Seçilmemiş
WM Aracı
 
Üyelik Tarihi: 20 Ocak 2018
Yaş / Cinsiyet: 28 / Erkek
Meslek: Memur
Ad, Soyad: Gü... Er...
Mesajlar: 138
Beğeniler: 19 / 114
Ticaret: 0, 0%
Selam Arkadaşlar;

Aşağıda linkini verdiğim sitede ikonlar linux hosting de görünmüyor ama localhostta çalışıyor neden böyle sunucuda eksik birşey mi var.

http://demo.themefisher.com/themefis...rox/index.html


CSS İKON KODU :

<link rel="stylesheet" href="http://demo.themefisher.com/themefisher/biztrox/plugins/themify-icons/themify-icons.css">

İKONUN RESMİ SİTESİ


https://themify.me/themify-icons
Konu bakarmsn tarafından (14 Ocak 2020, 16:02 ) değiştirilmiştir.
  #2  
Okunmamış 14 Ocak 2020, 16:19
ruzgarhost Adlı Üyenin Avatarı
WM Aracı
 
Üyelik Tarihi: 24 Nisan 2019
Yaş / Cinsiyet: 21 / Erkek
Meslek: Öğrenci
Konum: Sakarya
Ad, Soyad: Ca... Dü...
Mesajlar: 34
Beğeniler: 4 / 6
Ticaret: 0, 0%
Site adresinizi iletirseniz yardımcı olabilirim.
bakarmsn bunu beğendi.
  #3  
Okunmamış 14 Ocak 2020, 16:59
Avatar Seçilmemiş
WM Aracı
 
Üyelik Tarihi: 02 Kasım 2014
Yaş / Cinsiyet: 33 / Erkek
Ad, Soyad: Ay... Ak...
Mesajlar: 63
Beğeniler: 10 / 19
Ticaret: 0, 0%
css dosyasında iconsetin yolunu kontrol edin. Muhtemelen yolu yanlıştır.
bakarmsn bunu beğendi.
  #4  
Okunmamış 14 Ocak 2020, 18:24
Avatar Seçilmemiş
WM Aracı
 
Üyelik Tarihi: 20 Ocak 2018
Yaş / Cinsiyet: 28 / Erkek
Meslek: Memur
Ad, Soyad: Gü... Er...
Mesajlar: 138
Beğeniler: 19 / 114
Ticaret: 0, 0%
aydmem ruzgarhost

Arkadaşlar site dosyalarını farklı bir alan adındaki hosting e attım orada ikonlar çalış sizce neden hosting paketinde kapalı olan bir şey mi var anlayamadım ama pc'de localde çalışıyor başka hosting paketimde çalışıyor kendi hosting paketimde çalışmıyor ilginç
  #5  
Okunmamış 15 Ocak 2020, 15:07
emrecanoztas Adlı Üyenin Avatarı
Ninja Yazılımcı
 
Üyelik Tarihi: 24 Kasım 2018
Cinsiyet: Erkek
Konum: Ankara
Ad, Soyad: Em... Öz...
Mesajlar: 18
Beğeniler: 7 / 1
Ticaret: 0, 0%
Merhaba,

Site adresini paylaşmadığınız için hatanın ne olduğunu göremiyorum fakat tahminimce; CORS hatasına benziyor. CORS (Kökenler arası kaynak paylaşımı), kendi sunucunuz üzerinden başka bir sunucu üzerindeki dosya çağrılarında, cross-origin HTTP isteği oluşur. Bu da çoğu tarayıcı tarafından zararlı olarak algılanır. Böylelikle yapılan istek reddedilir.

CORS hatası da .htacces dosyasına eklenecek bir kaç satır ile düzeltilebilir.

Kod:
# =SEND CORS HEADER
# ==Images
<IfModule mod_setenvif.c>
    <IfModule mod_headers.c>
        <FilesMatch "\.(bmp|cur|gif|ico|jpe?g|png|svgz?|webp)$">
            SetEnvIf Origin ":" IS_CORS
            Header set Access-Control-Allow-Origin "*" env=IS_CORS
        </FilesMatch>
    </IfModule>
</IfModule>

# ==Fonts
<IfModule mod_headers.c>
    <FilesMatch "\.(eot|otf|tt[cf]|woff2?)$">
        Header set Access-Control-Allow-Origin "*"
    </FilesMatch>
</IfModule>
Yukarıdaki kodlar işinizi görecektir. Ben genellikle; kendi hazırladığım .htaccess dosyasını tüm projelerimde kullanırım. Dilerseniz; bu dosyayı da buradaki bağlantıdan indirebilirsiniz.
http://emrecanoztas.com/
  #6  
Okunmamış 15 Ocak 2020, 15:31
Avatar Seçilmemiş
WM Aracı
 
Üyelik Tarihi: 20 Ocak 2018
Yaş / Cinsiyet: 28 / Erkek
Meslek: Memur
Ad, Soyad: Gü... Er...
Mesajlar: 138
Beğeniler: 19 / 114
Ticaret: 0, 0%
emrecanoztas

Tema bootstrap css ikonları gelmiyordu pc'de localde ve başka bir siteyede attım dosyaları oradada sorunsuz direkt olarak görünüyordu baktım diğer hosting paketlerindede sorunsuz ve .htaccess dosyasına gerek olmadan çalışan tema diğer yeni olan sunucuda çalışmıyordu hosting servisine bildirdim sistemi restart vs. birşeyler yaptılar o zaman ikonlar görünmeye başladı.

O kadar çok site yaptım ama ilk kez karşılaştığım ilginç bir olaydı.

Teşekkürler Arkadaşlar Sorun Düzeldi.
  #7  
Okunmamış 15 Ocak 2020, 18:06
Avatar Seçilmemiş
WM Aracı
 
Üyelik Tarihi: 06 Nisan 2016
Yaş / Cinsiyet: 34 / Erkek
Ad, Soyad: Mu... Ça...
Mesajlar: 23
Beğeniler: 8 / 0
Ticaret: 0, 0%
Web sunucusu mimetype ayarı yapılmamış olabilir webfontlar için.
Php tarafını pek bilmiyorum ama IIS te bazen sıkıntı olabiliyor.
https://webplatform.github.io/docs/t...on_the_server/
woff uzantısı belki tanımlı değildir.
Hangi font tipini kullanıyordun?
Cevap Yaz Favorilerime Ekle


Konuyu toplam 1 kişi okuyor. (0 üye ve 1 Ziyaretçi)
 
Seçenekler
Stil
Normal Normal

Geri Git   Forum > HTML - CSS - XML


Yetkileriniz
Konu açma yetkiniz: Yok
Cevap Yazma Yetkiniz Yok
Eklenti yükleme yetkiniz: Yok
Mesajınızı değiştirme yetkiniz: Yok

BB code: Açık
İfadeler: Açık
[IMG] Kodları: Açık
HTML kodu: Kapalı




Tüm Zamanlar GMT +3 Olarak Ayarlanmış. Şu anki Zaman: 15:28.