Giriş Yap / Kayıt Ol

WM Aracı'na üyelikler tekrar açıldı! Kayıt olmak için TIKLAYIN!

2Beğeni
  • 1 Yazan MuhammedArslan
  • 1 Yazan Mrtcn

Cevap Yaz Favorilerime Ekle
Seçenekler Stil
Geri Git   Forum > > Sunucu Yönetimi

Nginx Konfigurasyon

  #1  
Okunmamış 11 Ocak 2019, 11:48
sworks Adlı Üyenin Avatarı
Kategori Moderatörü
 
Üyelik Tarihi: 28 Şubat 2018
Yaş / Cinsiyet: 24 / Erkek
Meslek: WordPress
Konum: Diğer
Ad, Soyad: Ah... Ko...
Mesajlar: 1.974
Beğeniler: 1020 / 1072
Ticaret: 12, 100%
Merhabalar,

Ubuntu 18.04 üzerine WordPress - Nginx kurdum.

Kod:
server {
listen 80;
root /var/www/html;
index index.php index.html index.htm;
server_name example.com www.example.com;
client_max_body_size 0;

error_page 404 /404.html;
error_page 500 502 503 504 /50x.html;

location / {
try_files $uri $uri/ /index.php?q=$uri&$args;
}

location ~* \.php$ {
if ($uri !~ "^/uploads/") {
fastcgi_pass unix:/run/php/php7.2-fpm.sock;
}
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
}
location = /favicon.ico {
log_not_found off;
access_log off;
}

location = /robots.txt {
log_not_found off;
access_log off;
allow all;
}

location ~* .(css|gif|ico|jpeg|jpg|js|png)$ {
expires 30d;
log_not_found off;
}
}
Sorunum şu, yukarıdaki benim default dediğimiz kurulumda eklediğim nginx konfigurasyonu. Buna ek olarak manuel bir şekilde Cloudflare 15 yıllık SSL sertifikasını sunucuya yükledim.

Bunu yukarıdaki konfigürasyona nasıl tanımlamam gerekiyor? Bir türlü güncel ve düzgün bir kaynak bulamadım.

Ayrıca DigitalOcean ipv6 desteğini de açık yaptım. ipv6 için bir şey eklemeli miyim?
  #2  
Okunmamış 11 Ocak 2019, 12:21
MuhammedArslan Adlı Üyenin Avatarı
Msa Web Tasarım
 
Üyelik Tarihi: 19 Şubat 2017
Cinsiyet: Erkek
Meslek: Web Developer
Konum: Bursa
Ad, Soyad: Mu... Ar...
Mesajlar: 910
Beğeniler: 277 / 136
Ticaret: 11, 100%
Şu şekilde ekleme yapmayı dener misin.

Kod:
listen 443 ssl;
ssl_certificate /etc/nginx/ssl/nginx.crt;
ssl_certificate_key /etc/nginx/ssl/nginx.key;
Tabiki sertifika yolunu kendine göre düzenlersin
sworks bunu beğendi.
  #3  
Okunmamış 11 Ocak 2019, 13:39
sworks Adlı Üyenin Avatarı
Kategori Moderatörü
 
Üyelik Tarihi: 28 Şubat 2018
Yaş / Cinsiyet: 24 / Erkek
Meslek: WordPress
Konum: Diğer
Ad, Soyad: Ah... Ko...
Mesajlar: 1.974
Beğeniler: 1020 / 1072
Ticaret: 12, 100%
MuhammedArslan öncelikle yardımınız için teşekkürler.
Peki 301 yönlendirmesi, ipv6 desteği sağlamak için ne yapmak gerekiyor acaba?

Sizin verdiğiniz koddan da yola çıkarak örnek bir konfigürasyon dosyası oluşturdum. Her şey sorunsuz çalışıyor fakat bazı kodlar işlev görmüyor.

Kod:
server {
listen 443;

charset UTF-8;

ssl on;
ssl_certificate /etc/cloudflare-ssl/example-com.pem;
ssl_certificate_key /etc/cloudflare-ssl/secretkey-example-com.key;
include /etc/cloudflare-ssl/options-ssl-nginx.conf;
ssl_client_certificate /etc/nginx/cloudflare.crt;
ssl_verify_client on;

root /var/www/html;
index index.php index.html index.htm;
server_name example.net www.example.net;
client_max_body_size 0;

error_page 404 /404.html;
error_page 500 502 503 504 /50x.html;

location / {
try_files $uri $uri/ /index.php?q=$uri&$args;
}

location ~* \.php$ {
if ($uri !~ "^/uploads/") {
fastcgi_pass unix:/run/php/php7.2-fpm.sock;
}
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
}
location = /favicon.ico {
log_not_found off;
access_log off;
}

location = /robots.txt {
log_not_found off;
access_log off;
allow all;
}

# REMOVE THIS LATER
add_header  X-Robots-Tag "noindex, nofollow, nosnippet, noarchive";

# X-XSS Protection
add_header X-XSS-Protection "1; mode=block";

# Deny access to uploads that are not images, videos, music, etc.
location ~* ^/wp-content/uploads/.*.(html|htm|shtml|php|js|swf)$ {
    deny all;
}
}

server {
    if ($host = www.example.net) {
        return 301 https://example.net$request_uri;
    } # managed by Certbot


    if ($host = example.net) {
        return 301 https://example.net$request_uri;
    }

listen 80;
server_name example.net www.example.net;
    return 404;

}
Örneğin alttaki kod sitemi açana kadar noindex yapmak için eklediğim bir kod.
Kod:
# REMOVE THIS LATER
add_header  X-Robots-Tag "noindex, nofollow, nosnippet, noarchive";
Bu kod mesela çalışmıyor. HTTP header'i kontrol ettiğimde noindex yazısı yok ama farklı bir kod çalışıyor. Bir türlü karmaşayı çözemedim
  #4  
Okunmamış 11 Ocak 2019, 14:01
Avatar Seçilmemiş
PrismaCSI
 
Üyelik Tarihi: 06 Eylül 2013
Yaş / Cinsiyet: 27 / Erkek
Konum: Ankara
Ad, Soyad: Me... Gö...
Mesajlar: 2.775
Beğeniler: 1487 / 404
Ticaret: 9, 100%
Örnek olması için;

nginx.conf - https://pastebin.com/8Ey7DHVm
headers - https://pastebin.com/LWZZEAD3
site.conf - https://pastebin.com/hY4Zj05j
sworks bunu beğendi.
Cevap Yaz Favorilerime Ekle


Konuyu toplam 1 kişi okuyor. (0 üye ve 1 Ziyaretçi)
 
Seçenekler
Stil
Normal Normal

Geri Git   Forum > Sunucu Yönetimi


Yetkileriniz
Konu açma yetkiniz: Yok
Cevap Yazma Yetkiniz Yok
Eklenti yükleme yetkiniz: Yok
Mesajınızı değiştirme yetkiniz: Yok

BB code: Açık
İfadeler: Açık
[IMG] Kodları: Açık
HTML kodu: Kapalı




Tüm Zamanlar GMT +3 Olarak Ayarlanmış. Şu anki Zaman: 16:46.